Slow response times and candidate search issues.
Incident Report for Newton Software
Resolved
All systems operational.
Posted Oct 01, 2019 - 22:16 UTC
Monitoring
Search cluster has recovered and response times are coming back to normal. Will continue to monitor.
Posted Oct 01, 2019 - 21:43 UTC
Identified
We have identified a hardware failure causing searches to be slow and affecting page load times. We are working to resolve this issue.
Posted Oct 01, 2019 - 20:50 UTC
This incident affected: Newton Dashboard and Career Pages.