Delayed email delivery
Incident Report for Newton Software
Resolved
All delayed emails have been reprocessed and delivered. All systems are operating normally at this time.
Posted Jan 02, 2019 - 20:29 UTC
Identified
We have identified and corrected the issue delaying email delivery. New emails should now be delivered as expected. We are actively working to get delayed emails delivered.
Posted Jan 02, 2019 - 18:21 UTC
Investigating
Newton engineers are investigating an issue where email delivery is delayed or stopped.
Posted Jan 02, 2019 - 16:49 UTC
This incident affected: Outbound Email.